Forum 2018-08-06T22:58:13+00:00
Notifications
Clear all

[Solved] Windows Security  

  RSS

HaPeKa
(@hapeka)
Active Member
Joined: 2 years ago
Posts: 19
29/08/2018 6:16 pm  

I tried to start the Firmware_Updater, but Windows does not allow it.
The error says "Diese Anwendung wurde vom Administrator blockiert, da sie potenziell ein Sicherheitsrisiko für Ihren Computer darstellt".
Even with UAC, Defender and Firewall disabled there's no way I get it running. 

Now, Pine has no firmware on it. 

Any tricks I can use?

Thanks

P.S. Is there a way to add a screenshot?


Quote
Moritz
(@moritz)
Black Forest Motion Admin
Joined: 2 years ago
Posts: 18
29/08/2018 6:58 pm  

Hi HaPeKa,

could be caused by your security settings. You can try this (German):

https://www.borncity.com/blog/2010/11/26/windows-sicherheit-blockt-setup-dateien/

You should be able to attach a file right under the text area.


ReplyQuote
HaPeKa
(@hapeka)
Active Member
Joined: 2 years ago
Posts: 19
29/08/2018 7:53 pm  

Hi Moritz,
I checked that already, with no success.
However, I installed the Updater on the Surface PC, and there I could allow it.
No clue, why it does not run on the Home PC.
Thanks for your support!


ReplyQuote
HaPeKa
(@hapeka)
Active Member
Joined: 2 years ago
Posts: 19
29/08/2018 9:57 pm  

Update worked, everything okay. 
I'll check the WIndows security again, maybe I can find out, what causes the blocking on the home PC and what's different at the laptop.
Basically, both are configured more or less identically ... 

Anyway, look forward to the first tests with PINE  🙂


ReplyQuote
lightuser
(@lightuser)
New Member
Joined: 7 months ago
Posts: 1
27/02/2020 12:23 pm  

I've tried three different Win 10 Pros. All patched with latest patches. None of the Windozers let me install BFM Updater.

I had success with pointing my explorer to the unzipped Firmware_Updater\Application Files\PineControllerUpdaterUtility_2_1_0_1 (or latest version) and renamed PineControllerUpdaterUtility.exe(.deploy) and bossac.exe(.deploy) - removing '.deploy'.

Updating PINE with PineControllerUpdaterUtility.exe worked.

Suggestion: maybe provide kind of a protable app you do not have to install. That should help IMHO.


ReplyQuote
Patrick
(@patrick)
Black Forest Motion Moderator
Joined: 2 years ago
Posts: 107
07/03/2020 12:29 pm  

Hi all,

here is a fix that will allow you to install the updater under Windows when you get messages like "Your administrator has blocked this application..."

  1. Open PowerShell as Administrator (that software should come pre-installed with Windows and you find it under the Start Menu as "Windows PowerShell")
  2. Make a right-click on it and then "Run as Administrator"
  3. Then you copy & past the lines below to the terminal in PowerShell. Just copy the lines first with your mouse cursor, then make a right mouse click into the terminal and it will paste and execute the commands automatically.
  4. Wait for the commands to finish executing.
  5. Then try to start the setup.exe file of our updater software again.

Lines to copy:

New-Item "HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel" -force | Out-Null
New-ItemProperty -path 'HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel' -Name 'Internet' -value 'Enabled'
New-ItemProperty -path 'HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel' -Name 'LocalIntranet' -value 'Enabled'
New-ItemProperty -path 'HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel' -Name 'MyComputer' -value 'Enabled'
New-ItemProperty -path 'HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel' -Name 'TrustedSites' -value 'Enabled'
New-ItemProperty -path 'HKLM:\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel' -Name 'UntrustedSites' -value 'Enabled'


ReplyQuote
Share: